Troubleshooting Guide

This help article applies to CloudShell 9.3. To see the latest, click here.

You are here: Quali Server > Cannot Download Packages from the PyPi Server

Cannot Download Packages from the PyPi Server

Error Message

Error: General Execution. Failed to start execution: Unexpected error – Failed to setup the python environment, error installing dependencies. The PyPi server process might be down or inaccessible. See the documentation and logs for more details.

Description

When attempting to run a python command that requires an external package, CloudShell serves the package to the Execution Server as follows:

  • The Execution Server downloads the package from the local PyPi Server repository on the Quali Server machine.

    or

  • If the package is missing from the local PyPi Server repository, Quali Server downloads it from the public python repository and then serves it to the Execution Server.

If CloudShell cannot access this package, the above error message is displayed.

Possible Causes

  • There is a firewall blocking port 443 over HTTPS (SSL port used by Quali Server/Execution Server to access the public python repository).
  • The local PyPi Server failed to run or stopped running.

Solution

Before performing any of the following steps, please review the log files at the following location on the relevant execution server machine:

C:\ProgramFiles(x86)\QualiSystems\TestShell\ExecutionServer\Logs\QsPythonDriverHost\InstallRequirements_XXXX.log

To determine if there is a firewall blocking port 443:

  • If the python command you are trying to run requires access to a package from the public python repository, verify that port 443 over HTTPS is open on the Quali Server and all execution server machines.

To investigate why the local PyPi Server failed to run:

  1. Check if the local PyPi Server is available by browsing to the Quali Server’s local PyPi Server (both from the Quali Server itself, and from the Execution Server machine): http://<Quali-Server-IP-or-hostname>:8036

    A "Welcome to pypiserver" page is displayed.

  2. If the page is not displayed, restart your local PyPi Server from CloudShell Monitor on the Quali Server machine.
  3. If you do not have online access, make sure all required packages are installed on your local PyPi Server. See the Loading packages to your PyPi Server repository section in CloudShell Help's PyPi Server - Managing Python Driver and Script Dependencies article.

  4. If you have a package on the local PyPI Server, but it is not the correct version according to the requirements of the python shell or script, you will need to load the specific version as well, see the Special considerations section of the above article.